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Major CADSTAR Enhancements... 

Visual Appearance 

A greater level of customisation is now offered through Themes, Collapsible Menus, and 
customisable Menu Buttons. 

Part Library Database 

You can now store the data which makes up the CADSTAR Parts Library in a Database. 

Starpoints 

Starpoints allow you to connect several nets together whilst avoiding the standard electrical 
checks that would otherwise take place. 

Laser Drilling Support 

You can now specify whether to use the Drill Oversize default for each via code in the Via 
Assignments dialog. 

Copy and Paste of Parts in the Library Editor 

It is now possible to copy and paste parts and part definitions. This is available within a Parts 
Library as well as to other Part Libraries. 

Variant Support for Design Reuse and Copy & Paste 

Reuse Blocks are now able to include items with variant hierarchies. Copy and paste can now 
also operate on variant items.  

Interactive Move in Embedded Place & Route 

You can now perform interactive move operations in the "Embedded Place and Route". 

Other CADSTAR Enhancements... 

Page 1 of 90Introduction

12/15/2011file://C:\Users\Doug\AppData\Local\Temp\~hh67F0.htm



Radial Dimensioning of Arcs 

You can now add radius and diameter measurements to Arcs. 

Opening Workspace Files  

Workspace Files now embed the file path of the workspace file in all file links. 

Exclusion of View Changes to Undo / Redo 

Any changes of view such as a Zoom, Frame View or View All are now excluded from the 
Undo and Redo functionality by default. This can still be re-enabled, from the Options dialog. 

Toggle Net Highlight Extended to Items 

You can now select any item that is connected to a net and select Toggle Net Highlight, the 
highlight state of all nets connected to the selected item(s) will be toggled. 

Highlight / Unhighlight Item Nets 

You can now easily highlight and unhighlight the nets connected to any selected item. 

Mix Colours Drawing Mode 

It is now possible to select a drawing mode that mixes the colours of overlapping PCB items, 
enabling a form of transparency.  

Archiving of Variants 

When archiving it is now possible to choose between archiving the current variant or all variants. 

Unroute Available on Context Menu 

You can now unroute a route by right mouse button clicking on the route and selecting Unroute 
from the Popup menu. 

Find Tool  

The find tool now informs the user with a warning message when nothing matching the search 
criteria was found. 

Design Rules Check Launches Report 

When the Design Rule Check  function encounters errors the Design Rule Check Report is now 
launched automatically. 

Save All When Authorisation Fails 
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If authorisation fails it is now possible save all open designs. 

Improved Algorithms for Route Offsetting and Suppress Inner Layer Pads 

The Route Offsetting and Suppress Inner Layer Pads algorithms have been upgraded which may 
result in a different electrical design compared to previous releases. 

P.R.Editor XR Enhancements... 

���������	
���
��� �

The Layer Stack Editor interface has been enhanced to improve its usability.  

Unroute Errors Tool 

A new tool has been introduced to remove erroneous items in the design. It can be used after an 
Autoroute operation to remove any errors remaining and turn them into connections. 

Routing and Fan-out Improvements 

Respect Fixed Escape Routing has been implemented and spiral vias can now be used in Fan-out 
generation for differential pairs. In addition, a Fan-out report has been added which appears 
during the Fan-out generation process. 

Select Items Updates 

Several improvements have been made to the Select Item dialog, including; enhanced wild card 
matching, pin selection on specific nets, filtering of net items, and extra Extend options. 

Selection Properties Improvements 

Improvements have been made to the Select Properties dialog to allow more control over the 
display when selecting. 

Stroke Gestures 

Stroke gesture support has been added for the standard set of strokes available in the Design 
Editor application such as panning and zooming. 

Separation Report Spacing Derivation 

it is now possible to easily identify where a spacing is derived from. When you measure the 
distance between two pins the center to center distance is now also outputted. 

Browse Errors Dialog Update 

A direct link to the Separation Report has been added to help in identifying errors and their 
resolution. Also, the dialog will now dynamically update as you clear errors from the design. 
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Attribute Editor 

Improvements have been made to the Template tab of the Attribute Editor. A Signal Name 
column has been added and it is now possible to sort the data by column. 

Toolbar Enhancements 

A Configure toolbar has been added and a Configure icon has been added to the Create / Edit 
Shape, Routing and Fan-Out toolbars. 

P.R.Editor XR HS Enhancements... 

Z0 and Zdiff Planning 

A new Layer Stack Editor has been implemented. This new tabbed dialog includes impedance 
control for single trace routing (Z0 Planning) and differential Pair Routing (Zdiff Planning). 
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New functions to control impedance have been incorporated into the Layer Stack Editor. It is 
now much easier to set the width and spacings in order to achieve target impedance values for 
single ended nets and differential pairs. 

Lengthening Improvements 

Lengthening blocks can make space for themselves, you can also lengthen the ends of Trunks in 
order to meet skew between the two halves of a Differential Pair. In addition, Trombone Style 
Lengthening is now available.  
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A new Select new items options has been added to the General tab of the Options dialog. This 
option allows you to specify which options are selected in the tree view when a new item is created. 
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It is now possible to copy and paste information between the Constraint Manager spreadsheet 
and external spreadsheet applications. 
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A Max Pin Pair Vias constraint has been added together with a Max Pin Pair Vias report. The 
report identifies the Max via constraint for a pin pair and the actual number of vias in the routed 
design. 
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It is now possible to stop simulation on any design items that have one or more default buffer 
models. This affects the Simulate Uncoupled, Simulate Coupled and Update Selected options. 
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You can now select a buffer model for a pin by selecting a device pin and applying a model for 
that pin. Also, some of the Advanced Filter options have been bought into the Model Selection 
dialog. 
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Several ease of use enhancements for the Scenario Editor have been introduced.  

Dragon Enhancements... 

Routing Strategy Dialog 

Several tools have been added to the list of Operations, a new Add Row button now adds a row 
above the currently selected step. 

Target Dialog 

The Target dialog has been enhanced to allow User Selections for targets. 
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The Routing Strategy Report has been updated to identify the nets that have Hard Fails on them. 
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Several extra checks have been added to the Routing Consultant. The Item Explanation Reports 
have been enhanced and a Generate button has been added. 
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Smart Fan-out and Escape Routing are now available as Fan-out generation options. 
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Visual Appearance  
This version of CADSTAR offers a greater level of customisation through the use of Themes, 
Collapsible Menus, and customisable Menu Buttons and your open document Tab Locations 
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Themes 

Under the 'Application Settings' tab in the 'Customise' dialog under the 'Tools' menu there are 
four different themes to choose between, all effect the appearance of the main CADSTAR 
application window in terms of its colour, you can change the selection in the box below to 
preview the theme; 

 

  

Collapsible Menus 

Under the 'Application Settings' tab in the 'Customise' dialog under the 'Tools' menu you can 
select 'Collapsible', this will hide menu items that are rarely used. Click on the arrow on the 
menu and the full list of options will appear. 
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Customisable Menu Buttons 

Buttons on toolbars can now be changed to include text, and replaced to be text only. If you click 
on 'Tools' -> 'Customise' and then right mouse button click on any toolbar button you are given 
the following menu; 
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To apply these type of options across the whole of the application choose the appropriate option 
from the 'Global Button Appearance' settings in the 'Application Settings' tab in the 'Customise' 
dialog;    

  

  

Examples of the effect of these options - 

Image Only: 
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Text below Image: 

 

  

Text on Right of Image: 

 

  

Text Only: 

 

  

  

Tab Locations 

You can choose whether the Tabs of your open documents appear on the top or bottom of the 
main application window. You can set your open designs to appear as tabs using the 'Tabbed 
Document' check box (also available from 'Window' -> 'Tabbed Documents'), and choose 
between 'Top' and 'Bottom' in the 'Tabs Location' grouping. If you change the setting you the 
main window will preview your change. 
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Part Library Database 
You can now store the data which makes up the CADSTAR Parts Library in a Database.  A 
various range of ODBC's can be setup using the 'Data Link Properties' dialog. 
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New options in 'File' menu to allow Opening and Saving of the Parts Database. CADSTAR Part 
Library files (.lib) can be opened and saved to the Database (and vice versa). 

 

No parts index is required.  After editing Parts you can use them straight away. Single parts can 
be edited and saved (instead of having to edit/save the whole Parts Library). 
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In 'Library Searcher', part data does not need to be loaded before filtering the search. This speeds 
up the process. 
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 CADSTAR Parts Database also allows easier integration with other PLM systems. 

  

Further information on configuring and operating databases can be found here 
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Starpoints 
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Starpoints allow you to connect several nets together whilst avoiding the standard electrical 
checks that would otherwise take place had you simply laid a piece of copper across different 
signalled items.  

Creation of Starpoints 

All Starpoints names must use the naming convention of starting with 'STARPOINTNF' 

- When creating a Starpoint component they must adhere to the following rules; 

     1. All the pins should have the same position 

     2. There should be a minimum of two pins 

     3. All pins must use the same pad code 

     4. All pins must have the same orient angle 

     5. All pins must be on the same side 

     6. All pins must have the same exit direction 

- When creating a Starpoint symbol it must be given at least two pins. 

- When creating a Starpoint part the library editor will check that the symbol does not have 
more pins than the component, and that both symbol and component are Starpoints. 

Adding Starpoints to Designs 

To add a Starpoint to a PCB or Schematic design click 'Add -> Starpoint'; 

     

The following dialog appears listing all available Starpoints, select the required Starpoint from 
the list and click 'Add' 
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Further help for Starpoints can be found here. 
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Laser Drilling Support 
The properties of laser drill holes can be different to that of mechanically drilled holes and 
therefore extra versatility has been added to accommodate them. It is now possible to choose 
whether to use the 'Drill Oversize' default for each 'Via Code'; 
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Copy and Paste Parts 
You can now copy complete part definitions including hierarchies in the Library Editor's 'Parts' 
tab using the new 'Copy Part' option. The copied parts are stored on the clipboard and can be 
pasted as a new part using 'Paste' into the same Library or to another Part Library. 

All Parts on selected rows are copied: 

 

  

The option is also available from the 'Edit' menu; 
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Variant Support for Design Reuse and Copy 
& Paste 
Reuse blocks have been extended to support variants and warnings are given prior to a part or 
symbol definition change. In addition copy and paste operations also works on variants, however 
you can disable this in the 'Interaction' tab of the 'Tools -> Options' dialog by un-ticking the 
'Copy And Paste Variant Symbols' box; 
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Interactive Move In Embedded Place & 
Route  
New features have been added to Embedded Place & Route to allow you to perform interactive 
move operations. There is a new option available on the 'Edit' menu called 'Component Focus' 
enabling you to select components; 
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The 'Select Mode' and 'Move Icons'  can be used to drag or move components 
interactively and the following options are then available from the context menu; 

        

Also, on the 'Placement' menu the following options are available many of which have settings 
dialogs accessible from the 'Settings -> Placement' menu; 
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Radial Dimensioning of Arcs 
It is now possible to add radius and diameter measurements to arcs. Simply chose 'Radius' or 
'Diameter' from the 'Add' menu (as you would for circles) and click on the arc at the point where 
you want the information to appear. 
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Opening Workspace Files  
If a workspace file and its associated files are moved the workspace file can still be opened as 
long as the relative directory paths remain consistent.  

If only the workspace file has been moved then files and folders associated with that workspace 
can still be opened from their absolute paths. A warning is displayed in this case.  

In the example below the Workspace 'workspace.csw' has been moved to a different drive. When 
CADSTAR opens this workspace file from its new location it will try the associated files' 
relative path first and then those files from their original paths; 
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Exclusion of View Changes to Undo / Redo 
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Any changes of view such as a 'Zoom', 'Frame View' or 'View All' are now excluded from the 
'Undo' and 'Redo' functionality by default. Therefore you will no longer see the following kind 
of command on the 'Edit -> Undo' option; 

      

However, it is still possible to re-enable it from the 'Tools -> Options' dialog by ticking the 
'Record View Changes' box; 
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Toggle Net Highlight Extended to Items 
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You can now select any item that is connected to a net and select 'Toggle Net Highlight', the 
highlight state of all nets connected to the selected item(s) will be toggled. The option is now 
also available from the context menu for both PCB and Schematic designs, as well as in 'move' 
mode. 

It is also available using the keyboard command 'T' see Toggle Command 

Example of selecting 'Toggle Net Highlight' for a symbol; 

            

                                  before                                                                      after     

  

...and for a component in PCB design 

                              

                                  before                                                                     after 
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Highlight / Unhighlight Item Nets 
It is now possible to highlight and unhighlight the nets connected to any selected item(s). Select 
an item and chose the relevant option from the 'Net Tools' grouping in the 'Edit' menu (the 
highlight state of all nets unconnected to the selected item(s) are unaffected). 

     

  

The options are also available when applicable from the context menus and when in 'move' 
mode. An example of the operation when selecting 'Highlight' and 'Unhighlight Item Nets' for a 
component in a PCB design is given below; 

  

                           

                After 'Highlight Item Net'                                        After 'Unhighlight Item Net' 

The functionality is particularly useful during the placement of components on the board as it 
allows a quick way of checking the net connectivity of components. 
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Mix Colours Drawing Mode 
It is now possible to select a drawing mode that mixes the colours of overlapping PCB items, 
enabling a form of transparency. In the PCB design editor / viewer choose 'Mix Colours' from 
the 'View' menu. For more information see Views - Mix Colours 

        

  

Section of PCB with Mix Colours disabled; 
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Section of PCB with Mix Colours enabled; 
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Archiving of Variants 
When archiving it is now possible to choose between archiving the current variant or all 
variants; 
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Unroute on Context Menu 
The 'Unroute' option is now available from the context menu in the PCB design editor when 
applicable (the option remains available under the 'Actions' menu) 
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Find Tool  
When the find tool does not find any results matching the search criteria, you are now given a 
message informing you of that; 
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Design Rules Check Launches Report 
When you run the 'Design Rules Check' and errors are found the 'Design Rule Check Report' 
will be invoked automatically, minimising the number of mouse clicks you have to perform this 
standard operation. 
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if errors are found in the 'Design Rules Check', the report will be launched; 
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Save All When Authorisation Fails 
If authorisation fails for some reason it is now possible to save all your changes to open designs. 
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Simply select 'Save All and Exit' should the following dialog appear; 

     

You will then be prompted to save each of your open designs in turn. 
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Improved Algorithms for Route Offsetting 
and Suppress Inner Layer Pads 
The CADSTAR Route Offsetting and Suppress Inner Layer Pads algorithms have been upgraded 
which may result in a different electrical design compared to previous releases. 

In Design Editor the route offsetting algorithm has been updated for non circular pins and vias in 
order to match P.R.Editor. This version also sees an upgrade in both Design Editor and 
P.R.Editor for the Pad-Copper touching checks for Suppress Inner Layer Pads; the algorithm 
now uses the drill shape instead of the pin/via position.  

A warning message is given when opening PCB designs from previous versions, recommending 
you to run the Design Rules Check (DRC) report; 
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Routing Completion Modification 

The calculations used to generate route offset shapes have been modified so that CADSTAR 
now matches P.R.Editor.  

For example -  

 

  

Via Suppression Modification 

Via suppression has been changed to unify CADSTAR's suppression behaviour for both pads 
and vias. For inner layers the via is unsuppressed if the copper intersects the via's drill hole. 
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Refer here for the full dialog help .  
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Layer Stack Editor  
The Layer Stack Editor interface has been enhanced to improve its usability. The process of 
entering the data to setup the layer stack is now far more intuitive. 
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.  

  

Note the 'Z0 Planning' and 'Zdiff Planning' tabs are only available in P.R.Editor XR HS. 
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Unroute Errors Tool 
This tool can be used to remove erroneous design items. Typically this is used after an Autoroute 
operation to remove any errors remaining and turn them into connections.   
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The 'Unroute Errors' tool has the following sub-menu: 

                                                  

Each of the options will only work on items that are in the current selection set. In each case the 
minimum amount of items will be removed in order to clear the errors. Examples of this are 
shown below, in each case the items selected are highlighted in blue; 

 

                                                           Whole design selected 

 

                                                        Sub-set of design selected 

  

Segments 

When this option is selected the minimum number of track segments in order to clear the errors 
will be removed. The example below shows the before and after result of this; 
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                                                                         Before 

                                     

                                                                           After 

  

Segments and Isolated 

When this option is selected, the minimum number of track segments will be removed. Also, any 
hanging track segments will be removed. The example below shows the before and after result 
of this; 
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                                                                           Before 

                                        

                                                                              After 

  

Node to node 

When this option is selected, the minimum number of track segments node to node will be 
removed. The node to node items will match those items that would be selected if you selected a 
track segment using node to node selection. The example below shows the before and after result 
of this; 
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                                                                           Before 

                                        

                                                                             After 
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Routing and Fan-out Improvements 
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Respect Fixed Escape Routing 

This option has been added to the 'Manual/Autorouting' tab, the option will force the autorouter 
to route to escape routing even if this is not the optimal result. This will typically be used for 
BGA type components where escape routing has been generated as part of the Fan-out 
generation process. 

 

  

Differential Pair Routing 

Improvements have been made in the Fan-out generation for differential pairs so that spiral vias 
can now be used if these are defined in your design.  

Fan-out Report 

A Fan-out Report has been added which appears during the Fan-out generation process; 
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Select Items Update 
Select Pins By Net 

This option allows you to select a set of nets and components in a sub dialog. The 'Select Items' 
dialog will then have the set of pins on the selected components with the selected nets attached. 
The example below is selecting the pins on the selected components that have a power net 
attached; 
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You can now use the Shift key in the tree view for greater flexibility of Item selection. 

The Wild Card Selection feature has been enhanced; 

 

  

Extra options have been added to the 'Extend' section of the dialog, Pins to Escape Routing and 
Pins to Trunk Ends; 
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In Trunk Items  has been added as an extra option to the 'Filter Net Items' section of the dialog; 
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Selection Properties Improvements 
Improvements have been made to the 'Select Properties' dialog to allow more control over the 
display when selecting. It is also possible to configure the behaviour of the 'Select/Move' icon 
using this dialog; 
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Stroke Gestures 
Strokes allow you to manipulate the P.R.Editor canvas by making a continuous mouse drag 
movement. This is achieved by holding down the right mouse button and dragging in order to 
perform an operation, as shown below; 
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The table below outlines the current set of supported gestures and their meanings; 
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Separation Report - Spacing Derivation 

Improvements have been made to the use of the 'Separation Report Tool' ; 

It is now possible to easily identify where a spacing is derived from; 

 

  

Also, when you measure the distance between two pins the center to center distance is now also 
output; 
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Browse Errors Dialog Update 
A link to the 'Separation Report' has been added to help in identifying errors and their resolution. 
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This is the 'Measure' hyperlink in the image below; 

 

  

Also, the dialog will now dynamically update as you clear errors from the design; 
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Attribute Editor 
A 'Signal Name' column has been added and it is now possible to sort the data by column, also 
the columns have been reordered to closely match the 'Copper Pour' dialog; 
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'Template Attributes' has also been added to the context menu of Templates. 
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The Configure Toolbar  

 

This toolbar allows access to some of the more commonly used options on the 'Configure' menu; 

Layer Stack 
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This icon will run the 'Layer Stack Editor'.  From here you can also configure impedance for 
single trace and differential pair routing. 

Attributes 

This icon will run the 'Attribute Editor'. 

Spacings 

This icon will run the 'Spacing Rules' dialog. 

The 'Configure' icon has also been added to the 'Create / Edit Shape', 'Routing' and 'Fan-Out' 
toolbars. 
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Z0 and Zdiff Planning 
Two new tabs on the enhanced 'Layer Stack Editor' have been implemented to enable the 
creation of Impedance Templates to control the impedance of single ended signals (Z0 Planning) 
and differential signals (Zdiff Planning); 

Z0 Planning Tab 

The 'Z0 Planning' tab is shown in the figure below: 

Page 55 of 90Introduction

12/15/2011file://C:\Users\Doug\AppData\Local\Temp\~hh67F0.htm



 

Impedance Template Section 

This section of the dialog allows you to add, delete and rename templates. You can select the 
current template from the drop down list. Note that the name of the impedance template will be 
displayed in red if the impedance template is illegal. This will be so in either of the following 
cases: 

�     The impedance, width or spacing for one or more layers cannot be calculated 

�     The calculated width is smaller than the minimum width allowed for the design 

The layers that this applies to will not have values displayed in the spreadsheet, as shown in the 
following figure; 
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The OK button will be disabled if any templates are illegal. You can add, rename and delete 
templates 

Template Solver Section 

There are two options, 'Solve Current' and 'Solve All'. 'Solve Current' Calculates the currently 
displayed template, taking into account any changes that have been made. The 'Width', ' Z0' and 
'Velocity' values are updated in the spreadsheet, as appropriate. 'Solve All' calculates all 
templates, taking into account any changes that have been made. 

If you change the layer stack in the 'Layer Stack' tab, you are prompted to update the impedance 
templates when you select the 'Solve' option. 

Spreadsheet Section 

The spreadsheet displays the 'Width', 'Z0' and 'Velocity' values for each conductor layer in the 
layer stack. You will typically define an impedance template in one of two ways: 

� Specify width values and calculate the impedance: 

 

� Specify impedance values and calculate the width: 
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When an impedance template is first created, the 'Width' value is typically set at the 'All' level to 
be the board level value of net width attribute. If you select the 'Calculate Template' option 
without making any other changes, impedance values will be calculated using this width value. 
However, if you explicitly type in a target impedance value, the default width value is ignored: 

                                 

In either mode, 'Velocity' values are calculated and displayed, these values cannot be changed. 
You can specify the required width or impedance at two levels: 

� Values set at 'All' level apply to all layers that don't have an explicit value set, as shown in 
the figures above 
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� Values set on a particular layer are used to calculate the values for that layer only 

               

Note that it is also possible to specify both the width and impedance values. In this case, no 
values are calculated. 

                                

Zdiff Planning Tab 

This tab allows you to define the values required to control the impedance of differential pairs. 
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The tab works in a similar way as the 'Z0 Planning' tab, described above, with the exception that 
the information in the spreadsheet is different. 

User editable values. 

There are three user editable values in the 'Zdiff Planning' tab, 'Width', 'Spacing' and 
'Z_diff' (differential impedance). In general, you must specify two out of the three values, and 
the third value will be calculated. As with 'Z0 Planning tab', default values can be specified at 
the 'All' level, and explicit values set on individual layers. 

                 

If you specify fewer than two values for any layer, the third value will not be calculated 
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The following result values are calculated, and are not editable by the user: 

� Z_odd - Odd mode impedance 

� Z_even - Even mode impedance 

� Z_common - Common mode impedance 

� v_diff - Differential velocity 

� v_odd - Odd mode velocity 

� v_even - Even mode velocity 

� v_common - Common mode velocity 

Applying templates to design items 

Once an impedance template has been defined, it can be set on a design item in one of the 
following ways: 

� Using the 'Impedance Template' column in the 'Constraint Manager' spreadsheet. This is in 
the 'Impedance' tab by default. 
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� Using the 'Edit', 'Set Impedance Template' option in the 'Constraint Manager'           

                 

� Using the 'Set Impedance Template' on the tree view context menu in the 'Constraint 
Manager' 
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� Using the 'Set Impedance Template' option of the 'Routing' menu in 'Physical Editor' 
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When an impedance template has been set on an item, the spacings and widths are copied onto 
the target item, as appropriate, and the router will use these values to ensure that the required 
impedance values are achieved. In addition, impedance templates can be set hierarchically. 
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Improved Impedance Control  
An enhanced 'Layer Stack Editor' has been implemented and new functions to control impedance 
have been incorporated into the dialog. It is now much easier to set the width and spacings in 
order to achieve target impedance values for single ended nets and differential pairs. 

 

Controlling the impedance of electrical nets and differential pairs can now be done using 
impedance templates. An impedance template can be defined in the new 'Layer Stack Editor' and 
allows you to control the widths and impedances to be used for any layer in the design. Once an 
impedance template has been defined, it can be applied to different design items to control the 
routing widths. 

The following options have been added to Constraint Manager for impedance templates: 

A new 'Edit -> Set Impedance Template' menu option is available, and there is a new 'Set 
Impedance Template' option on the tree view context menu; 
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Lengthening Improvements 
The lengthener has been enhanced so that lengthening blocks can make space for themselves. 
This is available during both interactive and automatic lengthening operations and is configured 
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on the 'High Speed' tab of the 'Routing Setup' dialog. The lengthener has also been enhanced so 
that it is possible to lengthen the ends of Trunks in order to meet skew between the two halves of 
a Differential Pair. 

 

  

 In addition, 'Trombone Style Lengthening' has been introduced; 
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Control of Tree View Selection in Constraint 
Manager  
A new 'Select new items' option has been added to the 'General' tab of the 'Options' dialog. This 
option allows you to specify which options are selected in the tree view when a new item is 
created in the tree view. 
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� If the 'Select new items' option is selected, the focus changes to the new item 

� If the 'Select new items' option is deselected, the focus does not change, i.e. the originally 
selected items remain selected after the new item is created 
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Enhanced Copy and Paste 
It is now possible to copy and paste information between the 'Constraint Manager' spreadsheet 
and external spreadsheet applications. 

Information copied into the Windows paste buffer from an external application can be pasted 
into the 'Constraint Manager' spreadsheet;                                                                                     

 

Information copied into the Windows paste buffer from the 'Constraint Manager' spreadsheet can 
be pasted into an external application; 
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Note that it is not possible to copy and paste the cell headers, or the names of the design items. 
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Via Count Information 
A 'Max Pin Pair Vias' constraint has been added along with a matching result. 
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The constraint can be set for Net Classes, Buses, Differential Pairs, Skew Groups and Electrical 
Nets. Also a delay constraint can be set on an electrical net, this applies to the delay between 
each driver-receiver pair on the electrical net, unless a specific constraint has been set between a 
pin pair. If it has, that constraint is applied instead. 

Constraint hierarchy 

The following figure shows the hierarchy for the new 'Max Pin Pair Vias' constraint; 

                          

Note, the most constraining value from any higher level applies, not the value set at the lowest 
level. 

Max pin pair vias on a pin pair  

This constrains the maximum number of vias between the two pins in the pin pair. It can be set 
on pin pairs consisting of any combination of component pins. 

Max pin pair vias on an electrical net  

When this constraint is set on an electrical net, it constrains the maximum number of vias on any 
pin pair within the electrical net. 
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Max pin pair vias on a differential pair  

When this constraint is set on an differential pair, it constrains the maximum number of vias on 
any pin pair within either electrical net in the differential pair. 

Max pin pair vias on a bus  

When this constraint is set on a bus, it constrains the maximum number of vias on any pin pair in 
any item (electrcial net or differential pair) within the bus. 

Max pin pair vias on a skew group  

When this constraint is set on a skew group, it constrains the maximum number of vias on any 
pin pair in the skew group. 

Max pin pair vias on an electrical net class  

When this constraint is set on an electrical net class, it constrains the maximum number of vias 
on any pin pair in any electrical net in the net class. 

Max pin pair vias report 

Selecting the 'Max Pin Pair Vias' report from the 'Utilities' menu will produce a report similar to 
the below for the selected design items. This lists the maximum via constraint for each selected 
pin pair, as well as the number of vias in the design; 
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Stop Simulation on Default Models 
It is now possible to stop simulation on any design items that have one or more default buffer 
models. This effects the following options; 

�  Simulate Uncoupled  

If any default buffer models are used, the simulation window will be displayed but no waveform 
is shown. A message will be      displayed that shows which pins have default models. You can 
assign models in the 'Data' tab and display a waveform. 
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� Simulate Coupled  

If any default buffer models are used, either in the target net or any of the aggressor nets, the 
simulation window will be displayed but no waveform is shown. A message will be displayed 
that shows which pins have default models. You can assign models in the 'Data' tab and display 
a waveform. 

� Update Selected  

If any of the electrical nets or differential pairs currently selected use default buffer models, no 
results will be returned by the simulator and 'No result' will be displayed in the spreadsheet; 

 

This is configured in the hs_config.ini configuration file. 
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Improved Model Selection Functions in 
Scenario Editor 
The following changes have been made to the 'Scenario Editor' to make it easier to change the 
buffer models used in the scenario.                                                                                     

New Assign Pin/Model option 

A new 'Assign Pin/Model' option has been added. This option allows you to select a buffer 
model for a pin by selecting a device pin, and applying a model for that pin. It is not necessary to 
remember the names of buffer models, and not necessary to browse through a list of buffer 
models to find the model required. 
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This option has been added to the toolbar ( ), the 'Edit' menu and the right mouse menu. A 
button has also been added to the 'Model Information' dialog. 

Enhancements to the existing Model Selection dialog 

The filter options on the existing 'Model Selection' dialog have been improved. Options that 
were previously only available using the 'Advanced Filter' option are now shown on the main 
'Model Selection' dialog. 

Page 76 of 90Introduction

12/15/2011file://C:\Users\Doug\AppData\Local\Temp\~hh67F0.htm



  

 

In addition, 'Assign Model' options have been added to allow the 'Model Selection' dialog to be 

displayed from the toolbar ( ) , the 'Edit' menu and the right mouse menu. 
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Scenario Editor Enhancements 
Several enhancements have been implemented to make Scenario Editor easier to run and use. 

Creating Empty Scenarios  

In earlier releases, if you wanted to create an empty scenario, it was necessary to use the 'Edit -> 
New Scenario' menu option, or the 'New -> Scenario' context menu in the tree view, and then 
select the 'Empty' option on the 'Create Scenario' dialog. 
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You can now create an empty scenario directly by using the 'Scenario Editor' icon or menu 
option.  

 

Whether the scenario is empty or contains the currently selected design items depends on which 
item is currently selected in the tree view. 

Supply nets in scenarios  

All the supply nets (power and ground) in the current design are now added to each new scenario 
you create. 
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Alternatively, if there is no design data, or the design data has no supply nets, a standard set of 
supply nets is added to the scenario automatically. 
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Set Stimulus Option 

A 'Set Stimulus' option has been added to 'Scenario Editor' to allow you to set the stimulus on 
any drive-capable pin. This means that it is no longer necessary to return to 'Constraint Manager' 
to set stimuli, making the setup of scenarios quicker and easier. 

This option has been added to the toolbar ( ), to the 'Edit' menu and to the right mouse menu. 
It is also available on the 'Pin' tab of the 'Model Information' dialog. 

Drive Electrical Net Option 

A 'Drive Electrical Net' option has been added to the right mouse menu in 'Scenario Editor'. This 
option allows you to specify which drive-capable pin will be used as a driver when a simulation 
is run. This means that it is no longer necessary to return to 'Constraint Manager' to specify the 
driver, making the setup of scenarios quicker and easier. 

Default Model Menu Option 

A new 'Default Model' option has been added to the right mouse menu in 'Scenario Editor'. This 
is the same as the 'Default Model' option on the 'Pin' tab of the 'Model Information' dialog. 

Display Package Name 

The 'Model Information' dialog now has a 'Package Name' field on the 'Component' tab. 
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Routing Strategy Dialog  
There have been a number of new tools added to the list of 'Operations'; 

� Pulltight 

� Equispace 

� Run Python Command 

� Unroute Errors - Segments 

� Unroute Errors - Segments and Isolated 

� Unroute Errors - Node to Node 

The 'Add Row' button now adds a row above the current selected step 
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Target Dialog 
The 'Target' dialog has been enhanced to allow 'User Selections' for targets; 
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Routing Strategy Report - Hard Fails 
The 'Routing Strategy Report' has been updated to identify the nets that have 'Hard Fails' on 
them. A hard failure is a connection that, for some physical reason, is impossible to route .  
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Routing Consultant 
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The following extra checks have been added to the 'Routing Consultant';    

� Copper with no signal 

� Isolated Copper 

� Outer Templates marked as target for autorouting 

� Inner Templates not marked as target for autorouting 

� Invalid Differential Pair 

� Free Topology Differential Pair 

� Different Topologies on Differential Pair halves 

� Differential Pair with Branch 

� Route Width Checks Min<Width<opt<Max 

� Bond pads with no connection 

'Item Explanation Reports' have been enhanced to enable easier location and resolution of 
problems; 
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A 'Generate' button has been added to the 'Routing Consultant' in order to generate a routing 
strategy. This means that the 'Analyze' button is always available allowing multiple runs of the 
consultant in order to resolve problems with your design; 
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Fan-out Generation Enhancements 
New Fan-out tools have also been developed; 

Smart Fan-out (BGA)) 

Many of today's designs incorporate high pin count FPGA/BGA type components. Routing 
completion for these is key to improving routing performance and completion. This tool 
intelligently generates the Fan-out for such devices adapting the Fan-out pattern around 
obstacles that might otherwise cause Fan-out generation to fail. 

Escape Routing (BGA) 

This tool helps to further improve completion for BGA/FPGA components by generation of 
escape routing to a defined boundary from the Fan-outs. Working with Fan-outs already 
generated on a FPGA/BGA type component this tool intelligently generates escape routing to a 
defined boundary of the device.   
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